Suport » Temes i plantilles » Afegir any per codi

  • Solucionat trizgarmar

    (@trizgarmar)


    Hola, la plantilla que tinc no mostra l’any per codi.
    És – Hathor Versió: 3.4 (Per Imonthemes)- https://wordpress.org/themes/hathor/

    M’agradaria saber quines línes de codi i a quins arxius hauria d’afegir per poder visualitzar l’any.

    Gràcies

    Jo ho intentat amb total desconeixeça i no ha funcionat … a les dos línies que hi ha:
    <span class=”day”><?php the_time( (‘j’) ); ?></span>
    <span class=”month”><?php the_time( (‘M’) ); ?></span>

    Afegir aquesta:
    <span class=”year”><?php the_time (‘Y’) ); ?></span>

    Ho he afegit als tres arxius on he trobat el codi
    “template-blog.php” “tag.php” i “single.php”

S'està mostrant 6 respostes - de la 1 a la 6 (d'un total de 6)
  • Moderador cubells

    (@cubells)

    Doncs si ho has escrit tal i com dius hauria de funcionar.

    Veig que el quadre de dia i mes és petit.
    Pot ser el problema és que mitjançant css o javascript s’amaga l’any quan el poses i per això sembla que no funciona.

    Tens el lloc web en marxa perquè li pegui una ullada per dir-te si hi ha alguna cosa que amaga l’any?

    Hola Cubells,
    Gràcies per respondre (perdó però no he vist cap avís per mail i he entrat ara a mirar)

    La web es prova.capaç.cat

    Però ara mateix al anar a mirar el que em dius resulta que les pàgines principals no m’apareixen, la ruta surt be però la entrada del blog surt buida així que no ho puc comprovar.

    No se que he tocat perquè de cop i volta no es carregui la pàgina principal, vaig a buscar algún fil per aquí i quan ho solucioni ho miro i et dic.

    Moltes gràcies

    Moderador cubells

    (@cubells)

    No entenc quin és el teu problema.

    Pots explicar-te millor?

    El segon problema solucionat en un altre post.

    La línea de codi afegida
    <span class=”year”><?php the_time (‘Y’) ); ?></span> Suposo que no la vaig posar be i m’ha fet l’error ja sol·lucionat.

    Ho acabo de mirar al codi i la pàgina veig que no em carrega cap línea amb l’any, així que no es que estigui ocult per algun estil:
    Per exemple aquí:
    http://prova.capaç.cat/2014/06/record-de-la-9a-distrobada/

    Suposo que en algún lloc em deixo dir que “cridi” al any “?php the_time (‘Y’) ); ?”

    Doncs ara un altre cop el mateix error, afegir aquesta línea

    <span class=”year”><?php the_time (‘Y’) ); ?></span>

    al arxiu de l”Entrada” “single.php” despres de:
    <span class=”day”><?php the_time( (‘j’) ); ?></span>
    <span class=”month”><?php the_time( (‘M’) ); ?></span>

    Fa que no funcioni res de la pàgina principal de la entrada del article.

    No he pensat a mirar si hi ha foro en anglès per aquesta plantilla, vaig a mirar.

    Tooot aquest embolic per culpa de deixarme “(“

    Ja funciona, ja apareix l’any correcte!

    Gràcies cubells per la teva atenció!

S'està mostrant 6 respostes - de la 1 a la 6 (d'un total de 6)
  • El tema «Afegir any per codi» està tancat a noves respostes.