Aquesta extensió no s'ha provat en les darreres 3 versions majors del WordPress. Segurament no està mantinguda o suportada, i pot tenir problemes de compatibilitat quan s'usa en versions recents del WordPress.

WP Code Prettify

Descripció

This plugin enable syntax highlighting of code snippets in your post using Google Code Prettify.

Característiques

  • More styles.
  • Colors can be customized.
  • The js/css files can be pre-loaded or post-loaded.
  • No js/css files are loaded if there is no code.

Captures

  • The settings menu

Instal·lació

  1. Upload the full directory into your wp-content/plugins directory
  2. Activate the plugin at the plugin administration page
  3. Open the plugin configuration page, which is located under “Settings -> WP Code Prettify” and customize settings.

PMF

What is it?

This plugin enable syntax highlighting of code snippets in your post using Google Code Prettify.

Ressenyes

3 setembre 2016
works on wordpress 4.4.1. thank you for solving the bug.
Llegiu totes les 3 ressenyes

Col·laboradors i desenvolupadors

"WP Code Prettify" és programari de codi obert. La següent gent ha contribuït en aquesta extensió.

Contribuïdors

Registre de canvis

0.2.8

  • Tested up to: 5.2

0.2.7

  • fix security issues;

0.2.6

  • fix “undefined index: head_custom”;

0.2.5

  • custom HTML can be add into \<head>, so you can include some js files, such as lang-matlab.js;
  • using plugins_url() instead of content_url();
  • Tested up to: 4.4

0.2.4

0.2.3

0.2.2

  • Tested up to: 3.9.0

0.2.1

  • Tested up to: 3.8.1

0.2.0

  • fix links of js/css files via https

0.1.9

  • update google code prettify to 4-Mar-2013 (fix css files)

0.1.8

  • update google code prettify to 4-Mar-2013

0.1.7

  • fix some warning.
  • improve options page

0.1.6

  • Tested up to: 3.4.2

0.1.5

  • fix “You do not have sufficient permissions to access this page.”.

0.1.4

  • fix “Notice: Undefined index: wpcp_update_options”.
  • Tested up to: 3.4.1

0.1.3

  • update version number.

0.1.2

  • fix “You do not have sufficient permissions to access this page.”.

0.1.1

  • update version number.

0.1.0

  • first version.